Lost Alpha Encountered Bugs

General talk about Lost Alpha dream project

Moderators: jwknaggs, CruxMDQ, Nemo

Re: Lost Alpha Encountered Bugs

Postby exostalker » Sat May 03, 2014 4:12 pm

A bunch of different CTD's, all received when trying to reach level changer to pripyat outskirts, from radar:

1. stack trace:

0023:70CC6B00 xrCore.dll, str_container::dock()
0023:6EF70E0C xrGame.dll, CDialogHolder::operator=()
0023:6EF66EDA xrGame.dll, CDialogHolder::operator=()
0023:6EF7223A xrGame.dll, CDialogHolder::operator=()
0023:6EF0D7A1 xrGame.dll, CDialogHolder::operator=()

no other info on that one

2. FATAL ERROR

[error]Expression : error handler is invoked!
[error]Function : invalid_parameter_handler
[error]File : xrDebugNew.cpp
[error]Line : 828
[error]Description :


stack trace:

0023:73213784 xrCore.dll, xrDebug::_initialize()
0023:7320D1D0 xrCore.dll, CInifile::r_section()
0023:70D305F6 MSVCR120.dll, _unDNameEx()
0023:70D306A2 MSVCR120.dll, atof_l()
0023:70D306D1 MSVCR120.dll, atof()
0023:7320ECC4 xrCore.dll, CInifile::r_float()
0023:6EF0D7A1 xrGame.dll, CDialogHolder::operator=()

3. Expression : fatal error
Function : CInifile::r_section
File : Xr_ini.cpp
Line : 499
Description : <no expression>
Arguments : Can't open section '%)/ -B†1U/¯ÿB¦1Õ'


-----------------------------

What's going on? Is the engine breaking or something?
exostalker
Newbie
 
Posts: 32
Joined: Sun Jul 04, 2010 9:48 pm

Re: Lost Alpha Encountered Bugs

Postby CruxMDQ » Sat May 03, 2014 4:17 pm

orbitaliz3d wrote:Don't know if this is a bug, but after that I found X-14 documents and killed all bloodsuckers I didn't received any quest progress message


Maybe you're missing one? The quest won't complete until you kill them all. Note that a couple of them are on some of the side rooms and may be hard to spot.
Got bugs? Read this before posting a report: viewtopic.php?f=3&t=1771

ANY bug reporting threads that fail to fulfill these conditions WILL BE CLOSED.
CruxMDQ
Moderator
 
Posts: 124
Joined: Sun Apr 27, 2014 9:43 pm
Location: Mar del Plata, Buenos Aires, Argentina, South America, Earth, Milky Way, Local Cluster, Multiverse

Re: Lost Alpha Encountered Bugs

Postby dez » Sat May 03, 2014 4:27 pm

exostalker, patch requires new game unfortunately, and still some bugs arent fixed completely.
everyone who used 3rd party mods, or hacks, fixes before the 1.30013 patch came out this morning should start new game, because saves wont work. modders added too many different files, and code, which was stored in savegames, which cant load them properly, and causing funnier than funnier bugs, and makes us totally a ghosthunter.
dez0wave developer
User avatar
dez
dez0wave developer
 
Posts: 1211
Joined: Tue Jun 24, 2008 9:22 am
Location: Hungary

Re: Lost Alpha Encountered Bugs

Postby ovs64 » Sat May 03, 2014 4:29 pm

CTD in Yantar Village.

Code: Select all
Expression    : fatal error
Function      : CModelPool::Instance_Load
File          : ..\xrRender\ModelPool.cpp
Line          : 117
Description   : <no expression>
Arguments     : Can't find model file 'weapons\bm_16_long\wpn_bm16.ogf'.
ovs64
Newbie
 
Posts: 4
Joined: Sat May 03, 2014 4:23 pm

Re: Lost Alpha Encountered Bugs

Postby orbitaliz3d » Sat May 03, 2014 4:34 pm

CruxMDQ wrote:
orbitaliz3d wrote:Don't know if this is a bug, but after that I found X-14 documents and killed all bloodsuckers I didn't received any quest progress message


Maybe you're missing one? The quest won't complete until you kill them all. Note that a couple of them are on some of the side rooms and may be hard to spot.


Im sure that every single one is dead. I heard mission beep and and quest looks completed in PDA http://oi57.tinypic.com/24dnbzp.jpg
maybe i find someone who will use them later in game
orbitaliz3d
Newbie
 
Posts: 3
Joined: Sat May 03, 2014 9:47 am

Re: Lost Alpha Encountered Bugs

Postby dez » Sat May 03, 2014 4:52 pm

ovs64 wrote:CTD in Yantar Village.

Code: Select all
Expression    : fatal error
Function      : CModelPool::Instance_Load
File          : ..\xrRender\ModelPool.cpp
Line          : 117
Description   : <no expression>
Arguments     : Can't find model file 'weapons\bm_16_long\wpn_bm16.ogf'.


Have you installed any weapon mod for LA?
dez0wave developer
User avatar
dez
dez0wave developer
 
Posts: 1211
Joined: Tue Jun 24, 2008 9:22 am
Location: Hungary

Re: Lost Alpha Encountered Bugs

Postby dez » Sat May 03, 2014 4:58 pm

orbitaliz3d wrote:
CruxMDQ wrote:
orbitaliz3d wrote:Don't know if this is a bug, but after that I found X-14 documents and killed all bloodsuckers I didn't received any quest progress message


Maybe you're missing one? The quest won't complete until you kill them all. Note that a couple of them are on some of the side rooms and may be hard to spot.


Im sure that every single one is dead. I heard mission beep and and quest looks completed in PDA http://oi57.tinypic.com/24dnbzp.jpg
maybe i find someone who will use them later in game


if you found he doc, take it back for sins, they gave you the task to find the doc :)
dez0wave developer
User avatar
dez
dez0wave developer
 
Posts: 1211
Joined: Tue Jun 24, 2008 9:22 am
Location: Hungary

Re: Lost Alpha Encountered Bugs

Postby exostalker » Sat May 03, 2014 6:29 pm

dez wrote:exostalker, patch requires new game unfortunately, and still some bugs arent fixed completely.
everyone who used 3rd party mods, or hacks, fixes before the 1.30013 patch came out this morning should start new game, because saves wont work. modders added too many different files, and code, which was stored in savegames, which cant load them properly, and causing funnier than funnier bugs, and makes us totally a ghosthunter.


Oh, I thought it's fully savegame compatible... And I didn't use any of those other mods, and user made fixes didn't really make any changes to saving/loading, but I guess I'm too far into the game to have it fully compatible:

Expression : m_ammoType < m_ammoTypes.size()
Function : CWeapon::net_Spawn
File : Weapon.cpp
Line : 500
Description : [IL 86] ammo type [128] ammo type size [2]
exostalker
Newbie
 
Posts: 32
Joined: Sun Jul 04, 2010 9:48 pm

Re: Lost Alpha Encountered Bugs

Postby ovs64 » Sat May 03, 2014 6:54 pm

dez wrote:
ovs64 wrote:CTD in Yantar Village.

Code: Select all
Expression    : fatal error
Function      : CModelPool::Instance_Load
File          : ..\xrRender\ModelPool.cpp
Line          : 117
Description   : <no expression>
Arguments     : Can't find model file 'weapons\bm_16_long\wpn_bm16.ogf'.


Have you installed any weapon mod for LA?


No mods at all, i never had crash in Yantar before patch 1.30013. But i did have the same issue with the missing p90 model.
ovs64
Newbie
 
Posts: 4
Joined: Sat May 03, 2014 4:23 pm

Re: Lost Alpha Encountered Bugs

Postby Robspassion » Sat May 03, 2014 7:56 pm

Hello,

I´m still experiencing crashes when rats attack me. I disabled the actors body, patched to v1.30013 and didn´t install any mods. Do I have to restart the game to get rid of this problem? I thought it´s fixed.

Regards
Robspassion
Newbie
 
Posts: 1
Joined: Sat May 03, 2014 7:49 pm

Re: Lost Alpha Encountered Bugs

Postby csubuka » Sat May 03, 2014 8:21 pm

dez wrote:exostalker, patch requires new game unfortunately, and still some bugs arent fixed completely.
everyone who used 3rd party mods, or hacks, fixes before the 1.30013 patch came out this morning should start new game, because saves wont work. modders added too many different files, and code, which was stored in savegames, which cant load them properly, and causing funnier than funnier bugs, and makes us totally a ghosthunter.



Dear dez!

I only have a small question: If I only used the new "ui_safe script" to get past the Borov safe mission, nothing else, then I must not start a new game right? Have not used any other "community fix", maybe you used the same method to fix it that the community used...

Other small thing:

I just found out that it is impossible to repair unique AK-s and the STALKER suit that can be found in Strelok's stash. At least Petrenko can not offer to repair them at the BAR when prompted for repairs... He can repair the Groza and the GP37 and regular AKs (can even see them together on the repair list while playing on a fullhd resolution, so the function works fine for me in most cases exept this one)... I think it might be a bug after all, since no other STALKER games had limitations concerning which equipment you can repair or not.

Best Regards
csubuka
Newbie
 
Posts: 7
Joined: Sat May 03, 2014 7:03 pm

Re: Lost Alpha Encountered Bugs

Postby exostalker » Sat May 03, 2014 9:23 pm

Okay, a few more:

1. http://i.imgur.com/phAiIOT.jpg

Monolith in radar near antennas

2. Can't return the machine to Lukash:

http://i.imgur.com/60PZpKx.jpg
http://i.imgur.com/ZxdlrtN.jpg
exostalker
Newbie
 
Posts: 32
Joined: Sun Jul 04, 2010 9:48 pm

CTD instantly when launch the game.

Postby jackycute » Sun May 04, 2014 3:35 am

Greeting!

I've patched with the latest one. v1.30013
But this bug still trapped me.
I looked up for this issue for a while.
Maybe it's a bug from OpenAL or not.
Thank you all and hoping to help me to play it!

* Detected CPU: Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz [GenuineIntel], F6/M10/S7, 3110.00 mhz, 29-clk 'rdtsc'
* CPU features: RDTSC, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2
* CPU threads: 4

Initializing File System...
using fs-ltx fsgame.ltx
FS: 53175 files cached, 9318Kb memory used.
Init FileSystem 33.277813 sec
Lost Alpha 'xrCore' build 5565, May 1 2014

EH: E52F6BF982292D12899856B86928CEA3

Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Loading DLL: xrRender_R3.dll
refCount:m_pAdapter 1
Executing config-script "user.ltx"...
[e:\stalker\s.t.a.l.k.e.r. - lost alpha\appdata\user.ltx] successfully loaded.
Loading DLL: xrRender_R1.dll
Loading DLL: xrGame.dll
* [win32]: free[4063852 K], reserved[33944 K], committed[96444 K]
* [ D3D ]: textures[0 K]
* [x-ray]: crt heap[18540 K], process heap[18540 K], game lua[0 K], render[0 K]
* [x-ray]: economy: strings[7367 K], smem[0 K]
SOUND: OpenAL: enumerate devices...
SOUND: OpenAL: EnumerationExtension Present
stack trace:

0023:76D959B5 MSCTF.dll, TF_CanUninitialize()
0023:76D9540D MSCTF.dll, TF_CanUninitialize()
0023:76D94A3E MSCTF.dll, TF_IsThreadWithFlags()
0023:76D965A1 MSCTF.dll, TF_CanUninitialize()
0023:76D96843 MSCTF.dll, TF_CanUninitialize()
0023:773553D8 IMM32.DLL, ImmEnumInputContext()
0023:76D961ED MSCTF.dll, TF_CanUninitialize()
0023:76D96D42 MSCTF.dll, CtfImeDestroyThreadMgr()
0023:76D96CF2 MSCTF.dll, CtfImeDestroyThreadMgr()
0023:77359B11 IMM32.DLL, ImmRequestMessageW()
0023:771E9134 combase.dll, CoRegisterInitializeSpy()
0023:771A4D3A combase.dll, CoInitializeEx()
0023:70F2C19B dsound.dll, DllGetClassObject()
0023:70F2C0C7 dsound.dll, DllGetClassObject()
0023:70F25C65 dsound.dll
0023:70F2A45B dsound.dll, DllGetClassObject()
0023:70F28DCB dsound.dll, DllGetClassObject()
0023:70F798F6 dsound.dll, DirectSoundFullDuplexCreate()
0023:10021D92 wrap_oal.dll, alcCloseDevice()
0023:77B2D1F3 ntdll.dll, LdrLoadDll()
0023:77B2CE92 ntdll.dll, LdrLoadDll()
0023:77B2CEB5 ntdll.dll, LdrLoadDll()
jackycute
Newbie
 
Posts: 2
Joined: Sun May 04, 2014 3:30 am

Repair Toolkit

Postby Faiakes » Sun May 04, 2014 2:00 pm

v1.30013
Win7 64

CTD when trying to repair sawn off shotgun

Code: Select all
XR_3DA.exe caused ACCESS_VIOLATION in module "C:\Program Files (x86)\S.T.A.L.K.E.R. - Lost Alpha\bins\xrGame.dll" at 0023:60D5709F, CDialogHolder::IR_UIOnKeyboardHold()+298431 byte(s)


EAX=00000000 EBX=88A731E0 ECX=6162EA0E EDX=60E62BE4
ESI=501DF9F0 EDI=5CD9D250 FLG=00010202
EBP=002DEFAC ESP=002DEF78 EIP=60D5709F
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

-----------------------------

Also, when trying to submut bug, XRay Engine freezes.

CruxMDQ wrote:Are you trying to use the repair kit, or you went to a technician?
Faiakes
Newbie
 
Posts: 14
Joined: Sun May 04, 2014 1:57 pm

Re: Lost Alpha Encountered Bugs

Postby Golden1984 » Mon May 05, 2014 12:32 pm

Crash during "meet monolith patriarch" mission

It happens everytime I come closer to patriarch matked on map, near to the crosroad with a fallen tree, after shooting down the helicopter.

Expression : fatal error
Function : CScriptEngine::lua_error
File : script_engine.cpp
Line : 75
Description : <no expression>
Arguments : LUA error: ...t.a.l.k.e.r. - lost alpha\gamedata\scripts\_g.script:264: attempt to index a nil value



___________________



registers:

EAX=1624FEB8 EBX=5FE87E98 ECX=0038A048 EDX=00000001
ESI=73C9D348 EDI=382B0018 FLG=00200212
EBP=0038AF34 ESP=00389F28 EIP=73C74168
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

NO MODS, 1.30013 patch
Windows 7 64

When I try to submit bug, window freezes, ctr+alt+del needed to get rid of it.

Please HELP!
CruxMDQ wrote:Issue added to list on bug-tracking thread.
Golden1984
Newbie
 
Posts: 5
Joined: Mon May 05, 2014 12:08 pm

PreviousNext

Return to Lost Alpha

Who is online

Users browsing this forum: No registered users and 1 guest

cron